[SOLVED] Spring Boot plugin requires Gradle 4.0 or later. The current version is Gradle X.X

Problem
Unable to execute Gradle task because of the message:

Error: Spring Boot plugin requires Gradle 4.0 or later. The current version is Gradle 3.3

Cause
Wrong Gradle Wrapper configuration or outdated Gradle version installed.
Solution A: (for Gradle stand-alone)
If you use stand-alone Gradle tool, you can just upgrade it to version 4.0 or newer.

The newest Gradle tool you can download it from here.

Please remember that the change may affects all projects which use system installed Gradle tool.


Solution B: (for Gradle Wrapper)
Open gradle/wrapper/gradle-wrapper.properties and change distributionUrl property to 4.6 version or newer one.

#Mon Mar 26 09:34:47 CEST 2018
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https://services.gradle.org/distributions/gradle-4.6-bin.zip


5 1 vote
Article Rating
Subscribe
Notify of
guest
1 Comment
oldest
newest most voted
Inline Feedbacks
View all comments
trackback
2 years ago

[…] First of all you have to upgrade Gradle Wpapper to use Gradle 4.0 or later what I described here. Then you have to edit build.gradle  and add exact version to the Spring Boot […]